ERROR: you should compile-aop